<!DOCTYPE html>
<html lang="en">
	<head  data-analytics-fields="">

		<meta charset="utf-8">
		
		<meta name="description" content="Stretch&#32;for&#32;Change:&#32;Stretch&#32;for&#32;Change&#32;is&#32;a&#32;work&#32;that&#32;will&#32;help&#32;people&#32;to&#32;adapt,&#32;and&#32;adapt&#32;well,&#32;in&#32;today’s&#32;fast-paced&#32;world.&#32;Stretch&#32;for&#32;Change:&#32;How&#32;to&#32;Improve&#32;Your&#32;Change&#32;Fitness&#32;and&#32;Thrive&#32;in&#32;Life&#32;by&#32;Gustavo&#32;Razzetti&#32;liberates&#32;people&#32;from&#32;fear&#32;and&#32;detachment,...">

		<meta property="fb:app_id" content="248269505352659">
		<link href="https://plus.google.com/+Forewordreviews/" rel="publisher">

		<link rel="image_src" href="https://www.forewordreviews.com/books/covers/stretch-for-change.jpg">
		<link rel="shortcut icon" href="/favicon.ico?v=0b338ca6a13eeabae74f8e758483d8437944979b">

		<title>	Review of Stretch for Change (9780999097304)
 — Foreword Reviews</title>
		<meta http-equiv="x-pjax-version" content="0b338ca6a13eeabae74f8e758483d8437944979b">
		<meta name="viewport" content="width=device-width, height=device-height, initial-scale=1.0, user-scalable=yes">

		<meta property="og:type" content="article"><meta property="og:title" content="Review&#32;of&#32;Stretch&#32;for&#32;Change"><meta property="og:url" content="https://www.forewordreviews.com/reviews/stretch-for-change/"><meta property="og:image" content="https://www.forewordreviews.com/books/covers/stretch-for-change.jpg"><meta property="og:description" content="Stretch&#32;for&#32;Change:&#32;Stretch&#32;for&#32;Change&#32;is&#32;a&#32;work&#32;that&#32;will&#32;help&#32;people&#32;to&#32;adapt,&#32;and&#32;adapt&#32;well,&#32;in&#32;today’s&#32;fast-paced&#32;world.&#32;Stretch&#32;for&#32;Change:&#32;How&#32;to&#32;Improve&#32;Your&#32;Change&#32;Fitness&#32;and&#32;Thrive&#32;in&#32;Life&#32;by&#32;Gustavo&#32;Razzetti&#32;liberates&#32;people&#32;from&#32;fear&#32;and&#32;detachment,...">
		<meta property="twitter:card" content="summary_large_image">
		<meta property="twitter:site" content="@ForewordReviews">
		<meta property="twitter:title" content="Review&#32;of&#32;Stretch&#32;for&#32;Change">
		<meta property="twitter:description" content="Stretch&#32;for&#32;Change:&#32;Stretch&#32;for&#32;Change&#32;is&#32;a&#32;work&#32;that&#32;will&#32;help&#32;people&#32;to&#32;adapt,&#32;and&#32;adapt&#32;well,&#32;in&#32;today’s&#32;fast-paced&#32;world.&#32;Stretch&#32;for&#32;Change:&#32;How&#32;to&#32;Improve&#32;Your&#32;Change&#32;Fitness&#32;and&#32;Thrive&#32;in&#32;Life&#32;by&#32;Gustavo&#32;Razzetti&#32;liberates&#32;people&#32;from&#32;fear&#32;and&#32;detachment,...">
		<meta property="twitter:image" content="https://www.forewordreviews.com/books/covers/stretch-for-change.jpg">

		<link rel="search" type="application/opensearchdescription+xml" href="https://www.forewordreviews.com/search/open.xml" title="Foreword Reviews Search">

		<link rel="stylesheet" media="screen" href="https://www.forewordreviews.com/css/0b338ca6a13eeabae74f8e758483d8437944979b/screen_style.min.css">
		<link rel="stylesheet" media="print" href="https://www.forewordreviews.com/css/0b338ca6a13eeabae74f8e758483d8437944979b/print_style.min.css">

		<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	ga('create', 'UA-5625248-3', {
		'cookieDomain': 'auto',
		'siteSpeedSampleRate': 50
	});

	
	var ga_fields = JSON.parse(
		document.getElementsByTagName('head')[0].getAttribute("data-analytics-fields") || "{}"
	);

	ga_fields.hitType = 'pageview';
	ga('send', ga_fields);
	ga_fields = null;

	ga('require', 'ecommerce');
</script>

<script type="text/javascript">
	!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
	n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
	n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
	t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
	document,'script','https://connect.facebook.net/en_US/fbevents.js');
	fbq('init', '1630029027293280'); 	fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1630029027293280&ev=PageView&noscript=1"
/></noscript>

<script>
fbq('track', 'ViewContent');
</script>

		<script src="https://www.forewordreviews.com/js/0b338ca6a13eeabae74f8e758483d8437944979b/jquery.min.js" defer></script>
		<script src="https://www.forewordreviews.com/js/0b338ca6a13eeabae74f8e758483d8437944979b/jquery.mobile.min.js" defer></script>
		<script src="https://www.forewordreviews.com/js/0b338ca6a13eeabae74f8e758483d8437944979b/mailcheck.min.js" defer></script>
		<script src="https://www.forewordreviews.com/js/0b338ca6a13eeabae74f8e758483d8437944979b/jquery.foreword.min.js" defer></script>
		<script src="https://www.forewordreviews.com/js/0b338ca6a13eeabae74f8e758483d8437944979b/jquery.pjax.min.js" defer></script>
		<script src="https://www.forewordreviews.com/js/0b338ca6a13eeabae74f8e758483d8437944979b/jquery.pjax.foreword.min.js" defer></script>
		<script src="https://www.forewordreviews.com/js/0b338ca6a13eeabae74f8e758483d8437944979b/modernizr.min.js" defer></script>
		<script src="https://www.forewordreviews.com/js/0b338ca6a13eeabae74f8e758483d8437944979b/table_sort.min.js" defer></script>
		<script src="https://www.forewordreviews.com/js/0b338ca6a13eeabae74f8e758483d8437944979b/track-forms.min.js" defer></script>
		<script src="https://www.forewordreviews.com/js/0b338ca6a13eeabae74f8e758483d8437944979b/ZeroClipboard.min.js" defer></script>
		<script src="https://www.forewordreviews.com/js/0b338ca6a13eeabae74f8e758483d8437944979b/ZeroClipboard.foreword.min.js" defer></script>

						
			<script>
				window.twttr = (function(d, s, id) {
					var js, fjs = d.getElementsByTagName(s)[0],
						t = window.twttr || {};
					if (d.getElementById(id)) return t;
					js = d.createElement(s);
					js.id = id;
					js.src = "https://platform.twitter.com/widgets.js";
					fjs.parentNode.insertBefore(js, fjs);

					t._e = [];
					t.ready = function(f) {
						t._e.push(f);
					};

					return t;
				}(document, "script", "twitter-wjs"));
			</script>
		

	<link rel="alternate" href="/reviews/feed.atom" type="application/atom+xml" title="Foreword Reviews - All Reviews">

				<script src="//use.typekit.net/czn8fga.js"></script>
		<script>try{Typekit.load();}catch(e){}</script>
	</head>
	<body>
		<div class="site-foreword&#32;section-reviews" id="body-inner">
							<div id="fb-root"></div>
				<script>
					(function(d, s, id) {
						var js, fjs = d.getElementsByTagName(s)[0];
						if (d.getElementById(id))
							return;
						js = d.createElement(s);
						js.id = id;
						js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=248269505352659";
						fjs.parentNode.insertBefore(js, fjs);
					}(document, 'script', 'facebook-jssdk'));
				</script>

				<div class="primary-header-wrapper">
											<div class="primary-search" id="primary-search">
	<div>
		<form action="https://www.forewordreviews.com/search/" method="get" accept-charset="UTF-8" class="header-search">
			<input type="search" name="q" id="primary-search-input" placeholder="Search our site..." title="Text Search:
cats
cats -dogs

Field Search:
title:cats
title:cats -dogs

Ranged Search:
pages:150..200
posted:2013..2014

Sorting:
sort:+pages
sort:-posted

All Together:
-dogs title:cats pages:100..150 sort:-posted">
		</form>
	</div>
</div>
						
<div class="primary-share" id="primary-share">
	<dl>
		<dt>Share:</dt>
		<dd>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F" target="_blank">
				<img src="https://www.forewordreviews.com/icons/share-buttons/facebook.png" width="32" height="32">
			</a>
		</dd>
		<dd>
			<a href="https://twitter.com/intent/tweet?text=Review&#32;of&#32;Stretch&#32;for&#32;Change:&#32;Stretch&#32;for&#32;Change:&#32;Stretch&#32;for&#32;Change&#32;is&#32;a&#32;work&#32;that&#32;will&#32;help&#32;people&#32;to&#32;adapt,&#32;and&#32;adapt&#32;well,&#32;in&#32;today’s&#32;fast-paced&#32;world.&#32;Stretch&#32;for&#32;Change:&#32;How&#32;to&#32;Improve&#32;Your&#32;Change&#32;Fitness&#32;and&#32;Thrive&#32;in&#32;Life&#32;by&#32;Gustavo&#32;Razzetti&#32;liberates&#32;people&#32;from&#32;fear&#32;and&#32;detachment,...%20%23selfhelp%20%23businessandeconomics%20%7C%20https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F%20via%20%40ForewordReviews&amp;related=forewordreviews" target="_blank">
				<img src="https://www.forewordreviews.com/icons/share-buttons/twitter.png" width="32" height="32">
			</a>
		</dd>
		<dd>
			<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F" target="_blank">
				<img src="https://www.forewordreviews.com/icons/share-buttons/googleplus.png" width="32" height="32">
			</a>
		</dd>
		<dd>
			<a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F&amp;description=Review%20of%20Stretch%20for%20Change%3A%20Stretch%20for%20Change%3A%20Stretch%20for%20Change%20is%20a%20work%20that%20will%20help%20people%20to%20adapt%2C%20and%20adapt%20well%2C%20in%20today%E2%80%99s%20fast-paced%20world.%20Stretch%20for%20Change%3A%20How%20to%20Improve%20Your%20Change%20Fitness%20and%20Thrive%20in%20Life%20by%20Gustavo%20Razzetti%20liberates%20people%20from%20fear%20and%20detachment%2C...&amp;media=https%3A%2F%2Fwww.forewordreviews.com%2Fbooks%2Fcovers%2Fstretch-for-change.jpg" target="_blank">
				<img src="https://www.forewordreviews.com/icons/share-buttons/pinterest.png" width="32" height="32">
			</a>
		</dd>
		<dd>
			<a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F&amp;title=Review%20of%20Stretch%20for%20Change&amp;summary=Stretch%20for%20Change%3A%20Stretch%20for%20Change%20is%20a%20work%20that%20will%20help%20people%20to%20adapt%2C%20and%20adapt%20well%2C%20in%20today%E2%80%99s%20fast-paced%20world.%20Stretch%20for%20Change%3A%20How%20to%20Improve%20Your%20Change%20Fitness%20and%20Thrive%20in%20Life%20by%20Gustavo%20Razzetti%20liberates%20people%20from%20fear%20and%20detachment%2C...&source=Foreword+Reviews" target="_blank">
				<img src="https://www.forewordreviews.com/icons/share-buttons/linkedin.png" width="32" height="32">
			</a>
		</dd>
	</dl>
</div>
						<nav class="primary-nav-account" id="primary-nav-account">
	<div class="primary-nav-account-inner">
		<p class="primary-nav-sites">
			<a href="https://awards.forewordreviews.com/">Foreword INDIES</a>
			<a href="https://publishers.forewordreviews.com/">For Publishers &amp; Authors</a>
	</p>
		<p>
							<a href="https://www.forewordreviews.com/login/"><img src="https://www.forewordreviews.com/icons/account.svg" width="16" height="16" alt=""> Log In</a>
			
			<a href="https://www.forewordreviews.com/cart/"><img src="https://www.forewordreviews.com/icons/cart.svg" width="16" height="16" alt="My Cart"></a>
			<a href="https://www.forewordreviews.com/search/" id="search-toggle-button"><img src="https://www.forewordreviews.com/icons/search.svg" width="16" height="16" alt="Search"></a>

							<a href="https://www.forewordreviews.com/share/?type=article&amp;title=Review+of+Stretch+for+Change&amp;url=https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F&amp;image=https%3A%2F%2Fwww.forewordreviews.com%2Fbooks%2Fcovers%2Fstretch-for-change.jpg&amp;description=Stretch+for+Change%3A+Stretch+for+Change+is+a+work+that+will+help+people+to+adapt%2C+and+adapt+well%2C+in+today%E2%80%99s+fast-paced+world.+Stretch+for+Change%3A+How+to+Improve+Your+Change+Fitness+and+Thrive+in+Life+by+Gustavo+Razzetti+liberates+people+from+fear+and+detachment%2C...&amp;hashtags%5B0%5D=%23selfhelp&amp;hashtags%5B1%5D=%23businessandeconomics" id="share-toggle-button"><img src="https://www.forewordreviews.com/icons/share.svg" width="21" height="16" alt="Share"></a>
					</p>
	</div>
</nav>
					
					<header class="primary-header">
						<div class="primary-header-inner">
							<span class="primary-logo"><a href="https://www.forewordreviews.com/"><img src="https://www.forewordreviews.com/logos/foreword-logo-book.svg" width="36" height="48"></a></span>
							<span class="primary-logo-name"><a href="https://www.forewordreviews.com/" tabindex="-1" rel="nofollow"><img src="https://www.forewordreviews.com/logos/foreword-logo-name.svg" height="48" alt="Foreword Reviews"></a></span>
															<nav class="primary-nav primary-nav-desktop" id="primary-nav">
									<button class="menu-toggle-button" id="menu-toggle-button">Menu</button>
									<ul><li><a href="https://www.forewordreviews.com/reviews/" 						 class="primary-nav-current"
					 >Book Reviews</a></li><li><a href="https://www.forewordreviews.com/articles/" >Articles</a></li><li><a href="https://www.forewordreviews.com/magazine/" >Magazine</a></li><li><a href="https://www.forewordreviews.com/about/" >About Foreword</a></li><li><a href="https://www.forewordreviews.com/subscriptions/" >Subscribe</a></li></ul>								</nav>
													</div>
						<nav class="primary-nav primary-nav-mobile" id="primary-nav-mobile">
							<ul><li><a href="https://www.forewordreviews.com/reviews/" 						 class="primary-nav-current"
					 >Book Reviews</a></li><li><a href="https://www.forewordreviews.com/articles/" >Articles</a></li><li><a href="https://www.forewordreviews.com/magazine/" >Magazine</a></li><li><a href="https://www.forewordreviews.com/about/" >About Foreword</a></li><li><a href="https://www.forewordreviews.com/subscriptions/" >Subscribe</a></li></ul>							<p class="primary-nav-sites">
			<a href="https://awards.forewordreviews.com/">Foreword INDIES</a>
			<a href="https://publishers.forewordreviews.com/">For Publishers &amp; Authors</a>
	</p>
						</nav>
					</header>
				</div>

								<div class="primary-header-spacer">
					<nav class="primary-nav-account" id="primary-nav-account">
	<div class="primary-nav-account-inner">
		<p class="primary-nav-sites">
			<a href="https://awards.forewordreviews.com/">Foreword INDIES</a>
			<a href="https://publishers.forewordreviews.com/">For Publishers &amp; Authors</a>
	</p>
		<p>
							<a href="https://www.forewordreviews.com/login/"><img src="https://www.forewordreviews.com/icons/account.svg" width="16" height="16" alt=""> Log In</a>
			
			<a href="https://www.forewordreviews.com/cart/"><img src="https://www.forewordreviews.com/icons/cart.svg" width="16" height="16" alt="My Cart"></a>
			<a href="https://www.forewordreviews.com/search/" id="search-toggle-button"><img src="https://www.forewordreviews.com/icons/search.svg" width="16" height="16" alt="Search"></a>

							<a href="https://www.forewordreviews.com/share/?type=article&amp;title=Review+of+Stretch+for+Change&amp;url=https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F&amp;image=https%3A%2F%2Fwww.forewordreviews.com%2Fbooks%2Fcovers%2Fstretch-for-change.jpg&amp;description=Stretch+for+Change%3A+Stretch+for+Change+is+a+work+that+will+help+people+to+adapt%2C+and+adapt+well%2C+in+today%E2%80%99s+fast-paced+world.+Stretch+for+Change%3A+How+to+Improve+Your+Change+Fitness+and+Thrive+in+Life+by+Gustavo+Razzetti+liberates+people+from+fear+and+detachment%2C...&amp;hashtags%5B0%5D=%23selfhelp&amp;hashtags%5B1%5D=%23businessandeconomics" id="share-toggle-button"><img src="https://www.forewordreviews.com/icons/share.svg" width="21" height="16" alt="Share"></a>
					</p>
	</div>
</nav>
					<div class="primary-header">
						<div class="primary-header-inner">
							<span class="primary-logo">&nbsp;</span>
						</div>
					</div>
				</div>

								<div class="primary-header-sizer" style="opacity:.5">
					<div class="primary-header" id="header-sizer">
						<div class="primary-header-inner">
							<span class="primary-logo"><a href="#" tabindex="-1"></a></span>
							<span class="primary-logo-name"><a href="#" tabindex="-1"></a></span>
							<nav class="primary-nav">
								<ul>
									<li>&nbsp;</li>
								</ul>
							</nav>
						</div>
					</div>
					<div class="page-sizer" id="page-sizer" style="background:lime;">&nbsp;</div>
				</div>

				<main class="primary-main" id="pjax-container">
							<div class="pjax-loading-progress-wrapper" data-pjax-dont-append="true">
		<div class="pjax-loading-progress-outer">
			<div class="pjax-loading-progress-inner">
				<h1 class="pjax-loading-progress-header" id="pjax-loading-progress-header">Loading...</h1>
				<progress class="pjax-loading-progress" id="pjax-loading-progress" max="100"></progress>
				<p class="pjax-loading-timeout">Taking too long? <a href="#" id="pjax-loading-timeout-retry">Try again</a> or <a href="#" id="pjax-loading-timeout-cancel">cancel this request</a>.</p>
			</div>
		</div>
	</div>

			
		

	

	<!-- consummo-performance-info -->

	
		<div class="primary-main-inner">
		<h1>Book Reviews</h1>

		<div class="section subnav"><div><ul><li class="current"><a href="https://www.forewordreviews.com/reviews/">All Book Reviews</a></li><li><a href="https://www.forewordreviews.com/reviews/editors-picks/">Editor's Picks</a></li><li><a href="https://www.forewordreviews.com/reviews/newest-releases/">Newest Releases</a></li><li><a href="https://www.forewordreviews.com/reviews/clarion/">Clarion Reviews</a></li><li><a href="https://www.forewordreviews.com/reviews/genres/">By Genre</a></li></ul></div></div>
		<div class="layout-two-column">
			<main>
				<article class="article"
								 itemscope
								 itemprop="review"
								 itemtype="http://schema.org/Review">
					<div>
						<span itemprop="itemreviewed">
							<h1>
																Stretch for Change
							</h1>
															<h2>How to Improve Your Change Fitness and Thrive in Life</h2>
													</span>

													<span itemprop="reviewRating"
										itemscope
										itemtype="http://schema.org/Rating">
								<span itemprop="ratingValue"
											content="4"
											></span>
							</span>
						
													<img src="https://www.forewordreviews.com/books/covers/stretch-for-change.w250.jpg"
									 width="250"
									 class="review-cover"
									 itemprop="image">
						
													<p>
																	Reviewed by
									<a href="https://www.forewordreviews.com/reviews/reviewers/melissa-wuske/"
										 itemprop="author"
										 itemscope
										 itemtype="http://schema.org/Person">
										<span itemprop="name">Melissa Wuske</span>
										<span itemprop="url"
													content="https://www.forewordreviews.com/reviews/reviewers/melissa-wuske/"
													></span>
									</a>
									<br>
																									<time title="Friday,&#32;August&#32;4,&#32;2017&#32;at&#32;11:58&#32;am&#32;EDT"
												datetime="2017-08-04T11:58:07-04:00"
												itemprop="datePublished"
												content="2017-08-04">
										August 4, 2017
									</time>
															</p>
						
						<span itemprop="reviewBody"><p class="money-quote"><em>Stretch for Change</em> is a work that will help people to adapt, and adapt well, in today’s fast-paced world.</p>
<p><em>Stretch for Change: How to Improve Your Change Fitness and Thrive in Life</em> by Gustavo Razzetti liberates people from fear and detachment, moving them into a life of effectiveness and purpose.</p>
<p>“Change is hard” is both an understatement and a universal truth. But change can also be the door to a new and better life, personally and professionally. Razzetti knows how to change well. He quit his job midcareer to start his own company. Here, he shares what he’s learned in order to help others face change, follow their dreams, and find success.</p>
<p>This book firmly asserts that change is good. Its three parts work to help people in all walks of life build their “change fitness”—their ability to face and even initiate change well—by addressing their personal roadblocks to change, using their readiness to change to solve meaningful problems, and becoming a leader who thrives and helps others thrive in times of change.</p>
<p>Razzetti’s innovative spirit is contagious—a true asset to the book and to his audience. His tone is friendly and inspirational, and yet he effectively eliminates excuses, like a coach. Each chapter is packed with commonsense, no-nonsense advice, along with relatable hypothetical examples, real-life examples, and Razzetti’s personal stories.</p>
<p>Included are exercises to make it easy to apply the concepts of each section. While this approach is intensely practical, much of what is shared is intangible and philosophical, as change is inherently a mental practice. By starting with purpose in mind, this model ensures that change takes place to increase meaning, not just for the sake of variety.</p>
<p>The book effectively destroys the notion that only some people are good at change. On the contrary, it says, all kinds of people—from different professions, with different personalities, and from different backgrounds—can be good at change. Many may be skeptical, but the text pushes past change aversion with practical support and positive thinking. It will help each individual come up with an approach to change that works for them, rather than a crafting a prescriptive solution for everyone.</p>
<p>Razzetti’s expertise in innovation and self-improvement is clear through the depth and well-thought-out structure of his approach, which impart confidence.</p>
<p>Access to an online community accompanies the book, built on the notion that no one can change on their own but that people working together are powerful. For many who struggle with the very thought of change, this collective approach will be the key to living differently than they ever have.</p>
<p><em>Stretch for Change</em> is a work that will help people to adapt, and adapt well, in today’s fast-paced world.</p>
</span>

						<p class="disclosure">
							<small>Disclosure: This article is not an endorsement, but a review. The author of this book provided free copies of the book and paid a small fee to have their book reviewed by a professional reviewer. Foreword Reviews and Clarion Reviews make no guarantee that the author will receive a positive review. Foreword Magazine, Inc. is disclosing this in accordance with the Federal Trade Commission’s 16 CFR, Part 255.</small>
						</p>
					</div>
				</article>

					<div class="ads" data-ads="house-wide;house-wide;"></div>

									<section class="comments">
						<h1 id="comments">Comment on this book</h1>
						<div class="fb-comments"
								 data-href="https://www.forewordreviews.com/reviews/stretch-for-change/"
								 data-numposts="5"
								 data-colorscheme="light"
								 data-width="300"></div>
					</section>
							</main>
			<aside>
				<div class="sidebar-widget-info-wrapper">
					<div class="sidebar-widget-info"
							 itemscope
							 itemtype="http://schema.org/Book">
						<h1>Book Information</h1>
						<dl class="widget-info">
															<dt>Author</dt>
								<dd>
									<a href="https://www.forewordreviews.com/books/contributors/gustavo-razzetti/"
										 itemprop="author"
										 itemscope
										 itemtype="http://schema.org/Person">
										<span itemprop="name">
											Gustavo Razzetti
										</span>
										<span itemprop="url"
													content="https://www.forewordreviews.com/books/contributors/gustavo-razzetti/"
													></span>
									</a>
								</dd>
							
															<dt>Publisher</dt>
								<dd>
									<a href="https://www.forewordreviews.com/books/publishers/liberationist-press/"
										 itemprop="publisher"
										 itemscope
										 itemtype="http://schema.org/Organization">
										<span itemprop="name">
											Liberationist Press
										</span>
										<span itemprop="url"
													content="https://www.forewordreviews.com/books/publishers/liberationist-press/"
													></span>
									</a>
								</dd>
							
															<dt>Genres</dt>
																	<dd>
										<a href="https://www.forewordreviews.com/books/genres/nonfiction/business-and-economics/"
											 itemprop="genre">
											Business &amp; Economics
										</a>
									</dd>
																	<dd>
										<a href="https://www.forewordreviews.com/books/genres/nonfiction/self-help/"
											 itemprop="genre">
											Self-Help
										</a>
									</dd>
															
							<dt>ISBN-13</dt>
							<dd itemprop="isbn">978-0-9990973-0-4</dd>

															<dt>Publication Date</dt>
								<dd itemprop="datePublished"
										content="2017-07-01">
									<a href="https://www.forewordreviews.com/search/?q%5Bpublished%5D=2017-07-01">
										Jul 1, 2017
									</a>
								</dd>
							
															<dt>Binding</dt>
								<dd>
									<a href="https://www.forewordreviews.com/search/?q%5Bbinding%5D=Softcover">
										Softcover
									</a>
								</dd>
							
															<dt>Pages</dt>
								<dd itemprop="numberOfPages">
									<a href="https://www.forewordreviews.com/search/?q%5Bpages%5D=294}">
										294
									</a>
								</dd>
							
															<dt>Price</dt>
								<dd>
									<a href="https://www.forewordreviews.com/search/?q%5Bprice%5D=17.99">
																					$17.99
																			</a>
								</dd>
							
							
							<dt>Download Review</dt>
							<dd>
								<a href="https://www.forewordreviews.com/reviews/stretch-for-change-review.pdf">
									Download
								</a>
							</dd>
						</dl>

													<dl class="widget-info">
								<dt>Tags</dt>
																	<dd>
										<a href="https://www.forewordreviews.com/search/?q=%23selfhelp"
											 >#selfhelp</a>
									</dd>
																	<dd>
										<a href="https://www.forewordreviews.com/search/?q=%23businessandeconomics"
											 >#businessandeconomics</a>
									</dd>
															</dl>
						
													<dl class="purchase-links">
								<dt>Purchase</dt>
																	<dd><a href="http://www.indiebound.org/book/9780999097304?aff=ForewordMag" target="_blank" rel="nofollow">IndieBound</a></dd>
															</dl>
						
													<dl class="widget-info star-ratings">
																	<dt>Clarion Rating</dt>
									<dd>
										<img src="https://www.forewordreviews.com/images/stars/4.png"
												 title="4&#32;Stars"
												 width="117"
												 height="21">
									</dd>
															</dl>
						
						
						<dl class="widget-info-share">
							<dt>Share</dt>
							<dd>
								
<div class="social-share">
	<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F" target="_blank">
		<img src="https://www.forewordreviews.com/icons/share-buttons/facebook.png" width="32" height="32">
	</a>
	<a href="https://twitter.com/intent/tweet?text=Review&#32;of&#32;Stretch&#32;for&#32;Change:&#32;Stretch&#32;for&#32;Change:&#32;Stretch&#32;for&#32;Change&#32;is&#32;a&#32;work&#32;that&#32;will&#32;help&#32;people&#32;to&#32;adapt,&#32;and&#32;adapt&#32;well,&#32;in&#32;today’s&#32;fast-paced&#32;world.&#32;Stretch&#32;for&#32;Change:&#32;How&#32;to&#32;Improve&#32;Your&#32;Change&#32;Fitness&#32;and&#32;Thrive&#32;in&#32;Life&#32;by&#32;Gustavo&#32;Razzetti&#32;liberates&#32;people&#32;from&#32;fear&#32;and&#32;detachment,...%20%7C%20https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F%20via%20%40ForewordReviews&amp;related=forewordreviews" target="_blank">
		<img src="https://www.forewordreviews.com/icons/share-buttons/twitter.png" width="32" height="32">
	</a>
	<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F" target="_blank">
		<img src="https://www.forewordreviews.com/icons/share-buttons/googleplus.png" width="32" height="32">
	</a>
	<a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F&amp;description=Review%20of%20Stretch%20for%20Change%3A%20Stretch%20for%20Change%3A%20Stretch%20for%20Change%20is%20a%20work%20that%20will%20help%20people%20to%20adapt%2C%20and%20adapt%20well%2C%20in%20today%E2%80%99s%20fast-paced%20world.%20Stretch%20for%20Change%3A%20How%20to%20Improve%20Your%20Change%20Fitness%20and%20Thrive%20in%20Life%20by%20Gustavo%20Razzetti%20liberates%20people%20from%20fear%20and%20detachment%2C...&amp;media=https%3A%2F%2Fwww.forewordreviews.com%2Fbooks%2Fcovers%2Fstretch-for-change.jpg" target="_blank">
		<img src="https://www.forewordreviews.com/icons/share-buttons/pinterest.png" width="32" height="32">
	</a>
	<a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.forewordreviews.com%2Freviews%2Fstretch-for-change%2F&amp;title=Review%20of%20Stretch%20for%20Change&amp;summary=Stretch%20for%20Change%3A%20Stretch%20for%20Change%20is%20a%20work%20that%20will%20help%20people%20to%20adapt%2C%20and%20adapt%20well%2C%20in%20today%E2%80%99s%20fast-paced%20world.%20Stretch%20for%20Change%3A%20How%20to%20Improve%20Your%20Change%20Fitness%20and%20Thrive%20in%20Life%20by%20Gustavo%20Razzetti%20liberates%20people%20from%20fear%20and%20detachment%2C...&source=Foreword+Reviews" target="_blank">
		<img src="https://www.forewordreviews.com/icons/share-buttons/linkedin.png" width="32" height="32">
	</a>
	<a href="https://www.forewordreviews.com/reviews/stretch-for-change/#comments">
		<img src="https://www.forewordreviews.com/icons/share-buttons/comments.png" width="32" height="32">
	</a>
</div>
							</dd>
						</dl>
					</div>
				</div>

					<div class="ads" data-ads="customer;customer;customer;"></div>
			</aside>
		</div>
	</div>
				</main>
				<div class="primary-footer-wrapper"><footer class="primary-footer"><p class="primary-footer-nav"><a href="https://www.forewordreviews.com/about/">About Us</a><a href="https://www.forewordreviews.com/faq/">FAQs</a><a href="https://www.forewordreviews.com/contact/">Contact Us</a><a href="https://www.forewordreviews.com/rights-catalog/">Rights Catalog</a><a href="https://www.forewordreviews.com/privacy/">Privacy Policy</a><a href="https://www.forewordreviews.com/terms/">Terms</a></p><p>ⓒ 2017 Foreword Magazine, Inc. All rights reserved.</p><h1 class="primary-social-follow-header">Choose Your Conversation:</h1><p class="primary-social-follow"><a href="https://www.twitter.com/ForewordReviews" target="_blank"><img src="https://www.forewordreviews.com/icons/share-icons/twitter.svg" width="17" height="20"></a><a href="https://www.facebook.com/forewordreviews" target="_blank"><img src="https://www.forewordreviews.com/icons/share-icons/facebook.svg" width="11" height="20"></a><a href="https://plus.google.com/+forewordreviews" target="_blank"><img src="https://www.forewordreviews.com/icons/share-icons/googleplus.svg" width="18" height="20"></a><a href="https://www.linkedin.com/company/foreword-reviews" target="_blank"><img src="https://www.forewordreviews.com/icons/share-icons/linkedin.svg" width="15" height="20"></a><a href="https://www.pinterest.com/forewordreviews" target="_blank"><img src="https://www.forewordreviews.com/icons/share-icons/pinterest.svg" width="19" height="20"></a><a href="https://www.forewordreviews.com/subscriptions/"><img src="https://www.forewordreviews.com/icons/share-icons/rss.svg" width="14" height="20"></a></p></footer></div>
				<div id="lightbox" class="lightbox"><button class="lightbox-close" title="Close">x</button><iframe></iframe></div></div>
			</body>
</html>
